Reseller Control Center Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Jul 07, 2026 - 16:33 UTC

Investigating

We are currently experiencing an issue affecting the Reseller Control Center. Customers may be unable to access the control panel. Thank you for your patience.
Posted Jul 07, 2026 - 16:20 UTC
This incident affected: Reseller Services (Reseller Program).