Support Services Degraded

Incident Report for GoDaddy

Resolved

This incident has been resolved.
Posted May 20, 2026 - 10:03 UTC

Update

We are continuing to investigate this issue.
Posted May 20, 2026 - 09:14 UTC

Investigating

We are currently investigating an issue that is impacting customer account logins and causing degraded performance in customer support services.
Posted May 20, 2026 - 06:39 UTC
This incident affected: GoDaddy Support (Messaging Support Services, Voice Support Services) and GoDaddy.com (GoDaddy Login Pages).