Payment Processing Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Jan 12, 2026 - 14:01 UTC

Investigating

We are currently investigating an issue impacting the ability to process GoDaddy Payments in India.
Posted Jan 12, 2026 - 11:28 UTC
This incident affected: GoDaddy Payments (Payment Processing).