Professional Email Degraded Accessibility

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Jun 16, 2025 - 08:23 UTC

Investigating

We are currently investigating an issue impacting the ability to login to email applications for the Professional Email service in Europe Region.
Posted Jun 16, 2025 - 07:54 UTC
This incident affected: Email & Productivity (Professional Email).