Nameserver Resolution Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Mar 16, 2026 - 23:09 UTC

Investigating

We are currently investigating an issue affecting the resolution of our Nameservers.
Posted Mar 16, 2026 - 20:17 UTC
This incident affected: Domain Services (DNS).