Support Services Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Jul 31, 2026 - 19:02 UTC

Investigating

We are currently investigating an issue causing both messaging and phone customer service support to be unavailable.
Posted Jul 31, 2026 - 17:10 UTC
This incident affected: GoDaddy Support (Voice Support Services).