Website Security Dashboard Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Jul 28, 2025 - 02:37 UTC

Investigating

We are currently investigating an issue causing the Website Security firewall administrative features to be unavailable and latent.
Posted Jul 27, 2025 - 12:15 UTC
This incident affected: Web Security (Website Security).