Microsoft Office 365 Email Degraded Services

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Oct 29, 2025 - 20:44 UTC

Investigating

We are currently investigating an issue impacting the ability to provision or delete Office 365 accounts.
Posted Oct 29, 2025 - 17:26 UTC
This incident affected: Email & Productivity (Professional Email with Microsoft 365).