Singapore Networking Connectivity Issues

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Jul 31, 2025 - 17:28 UTC

Update

We are continuing to investigate this issue.
Posted Jul 31, 2025 - 17:17 UTC

Investigating

We are currently investigating a networking issue in our Asian location that is impacting multiple services including support channels.
Posted Jul 31, 2025 - 17:13 UTC
This incident affected: GoDaddy Support (Messaging Support Services, Voice Support Services), Web Security (SSL Certificates), and Domain Services (DNS).