US Inbound Numbers All Down

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Apr 29, 2025 - 21:50 UTC

Investigating

We are investigating an issue that is causing all US inbound phone numbers to be down.
Posted Apr 29, 2025 - 21:45 UTC
This incident affected: GoDaddy Support (Voice Support Services).