GoDaddy Airo Provisioning Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Jun 12, 2026 - 15:37 UTC

Identified

We are currently experiencing an issue affecting provisioning for some Airo services.
Posted Jun 12, 2026 - 15:08 UTC
This incident affected: Websites and Stores (GoDaddy Airo).