Professional Email Degraded Accessibility
Incident Report for
GoDaddy
Resolved
This issue has been resolved.
Posted
Feb
28
,
2026
-
12:52
UTC
Investigating
We are currently investigating multiple issues affecting the Professional Email service in the European region.
Posted
Feb
26
,
2026
-
16:02
UTC
×
Subscribe to Incident
Subscribe to updates for
Professional Email Degraded Accessibility
via . You'll receive .