Support Services Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Mar 26, 2026 - 18:32 UTC

Investigating

We are currently investigating an issue causing both messaging and phone customer service support to be degraded.
Posted Mar 26, 2026 - 18:06 UTC
This incident affected: GoDaddy Support (Voice Support Services).