GD Payments User Interface Degraded
Incident Report for GoDaddy
Resolved
This issue has been resolved.
Posted Nov 12, 2024 - 23:47 UTC
Investigating
We are aware of an issue causing impact to the customer interface. Our engineers are working to correct this as soon as possible. Thank you for your patience.
Posted Nov 12, 2024 - 23:38 UTC
This incident affected: GoDaddy Payments (Payment Processing).