Online Store Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Jul 29, 2025 - 16:37 UTC

Investigating

We are currently investigating an issue that effects both the Store portion of the site and the dashboard to control the store. Thank you for you patience.
Posted Jul 29, 2025 - 16:03 UTC
This incident affected: Websites and Stores (Online Store Builder).