Shared Hosting Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Jul 18, 2025 - 20:14 UTC

Update

We are continuing to investigate this issue.
Posted Jul 18, 2025 - 17:25 UTC

Update

We are continuing to address degradation with Managed Wordpress Hosting.
Posted Jul 18, 2025 - 17:09 UTC

Update

We are continuing to investigate this issue.
Posted Jul 18, 2025 - 11:29 UTC

Investigating

We are currently investigating an issue causing websites on our Managed Wordpress Hosting and Web Hosting platforms to be unavailable in the American region.
Posted Jul 18, 2025 - 11:19 UTC
This incident affected: Web Hosting (Web Hosting) and WordPress Hosting (Managed WordPress Hosting 1.0).