Support Services Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Mar 17, 2026 - 12:16 UTC

Investigating

We are currently investigating an issue causing both messaging and phone customer service support to be unavailable in some locations.
Posted Mar 17, 2026 - 11:59 UTC
This incident affected: GoDaddy Support (Messaging Support Services, Voice Support Services).