The incident impacting the Contact Us button spinning have been resolved. Thank you for your patience, we apologize for any inconvenience this may have caused.
Posted Sep 12, 2023 - 21:17 UTC
Investigating
We are currently investigating an issue with the Contact Us button impacting Messaging Support Services Globally.
Posted Sep 12, 2023 - 20:36 UTC
This incident affected: GoDaddy Support (Messaging Support Services).